Jeff McCune home
VNC GuestDigging around in a NetBoot-Install.dmg file created by NetRestore Helper, I found a nice little gem. In Leopard, and perhaps earlier versions of Mac OS X, we're able to start a VNC server with the machine serial number as a password. This is particularly interesting for a managed network or lab environment. As an example, I'm starting a VNC server in my NetBoot-Install image with the following shell script:
# Credit to Mike Bombich for this snippet

VNC="/System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/Contents/MacOS/AppleVNCServer"

if [ -x "$VNC" ]; then
    "$VNC" -noRegister -serialNumber &
fi
I'm then able to quickly connect with Cmd+K in the finder: Connect to Server If you're scripting this, here's a quick way to snag the serial number. I do this before I bless a client machine to netboot, so I have the serial number to connect back up once it's in the NetRestore system.
system_profiler SPHardwareDataType | \
  grep -i 'serial number' | \
  perl -ple 's/.*:\s+(\w+).*?/$1/'
Fork me on GitHub